We are experiencing stability issues with our servers

Incident Report for Nofence

Resolved

This incident has been resolved.
Posted Feb 24, 2026 - 11:18 CET

Update

We have found and resolved the issue
Posted Feb 24, 2026 - 11:17 CET

Investigating

Our backend servers are experiencing some stability issues. The virtual fence is unaffected, but you may experience problems using the app. We are investigating.
Posted Feb 24, 2026 - 11:09 CET
This incident affected: Nofence.